Wrong Client Version Problem

#1

Hi,

When I try to run submission.py script of the osim-rl repository, I get this message:
“ServerErrorPrint Wrong client version. Please update to the new version. Read more on https://github.com/stanfordnmbl/osim-rl/docs 400 Wrong client version. Please update to the new version.”

I did not find in the docs any information about this error. I reinstalled everything from scratch but I still get the same message. It is clear that I am missing something obvious. Any idea how to solve this issue ?

Thank you!

Mohamed

#2

I had this same problem, just reinstalling stuff wouldn’t work for me, but fully creating it all in a new environment worked (i.e. creating opensim-rl2 env).

1 Like
#3

Thanks Ryan. Now it works!

1 Like