(Windows) Running MineRL Recording Mod Installer gives "Java Runtime Environment not found" error

#1

NOTE: This is a question about MineRL Dataset, not about the competiton.

I have installed Minecraft and downloaded the MineRL Recording Mod installer from this page. However, when I run the downloaded installer-signed.exe, I get the error message below:

error

This is on Windows 10, and I have JRE installed:

0 Likes

#2

I tried manually installing Mincraft Forge and downloading the mod (minerl.jar). This also doesn’t work, as double-clicking the jarfile does nothing.

When I run it on terminal, I get the following output:

$ java -jar .\minerl.jar
no main manifest attribute, in .\minerl.jar
0 Likes

#3

Were you able to resolve this issue?

If you have forge installed, the minerl.jar can be placed in your mods folder and you may join the server at mc.minerl.io

0 Likes

#4

For everyone’s future reference. If you download the miner.jar mod seperately after installing forge you have ot move it to your .minecraft/mods folder (google Minecraft folder location on <your platform here>)

1 Like

#5

I put the minerl.jar file in C:\Users\\[username]\AppData\Roaming\\.minecraft\mods.

When I try to connect to the MineRL server, it is stuck in Logging in… screen.


I attach a list of my mods:

I have a Ubuntu computer with the exact same versions, and that works well, so I don’t think it’s a version problem.

0 Likes

#6

Apologies, please try re-connecting, the issue should be resolved now.

1 Like

#7

It is indeed working now! Thank you for the help.

0 Likes