Unable to push file that "exceeds maximum limit"


When I tried to push a model built by random forest, I was not allow to push due to the following problem. May I ask your advice?

@shivam @ashivani

Many Thanks!

I think the answer is to use git-large-file-support (lfs), but I had the same problem and could not get it to work with the instructions provided by the AI Crowd team.

@ngewkokyew Please go through this. How to upload large files (size) to your submission

Hi @shivam,

Thanks for the response.

I tried to follow the instructions given but I couldn’t even proceed the first step.

Please advice.

Kind regards

Thanks @bjoern.holzhauer!

Yeah I did face the same problem even following the instructions provided, it seems like my other commits later on also facing the same issue. May I know do you have that problem as well?

Hi @ngewkokyew,

I remember the workspace have older git version (i assume) which don’t come with lfs, please install it using:

sudo apt-get update
sudo apt-get install git-lfs

Yes, I did and it took ages to fix. The problem was that the commits are still there, as pointed out by @lukas.widmer (have a look at git log). And brutally getting back to a previous state of the repo (after making sure to save any changes you want to retain in a different location) solved it. @josephmkahnnvs pinged me about the same problem last night, did git checkout -B master origin/master actually solve your issue, @josephmkahnnvs?

1 Like

Hi @ngewkokyew, @bjoern.holzhauer,

I assume the problem being mentioned here is, large files have been already commited and now no matter what you do git push rejects with above error?

If this is the case, please use the git lfs migrate command which ammend your git tree and fixes this problem. You may need to force push once this is done. https://github.com/git-lfs/git-lfs/wiki/Tutorial#migrating-existing-repository-data-to-lfs

1 Like

@shivam @bjoern.holzhauer

Thanks both! The issue is now resolved.

After installing lfs, the migrate command works fine for me.