Submitting Solution: Push Error and No code with current Tag

Hi While submitting solution using “” I am getting following error

Can you explain why I am getting the “failed to push error”.

Also, while looking at my gitlab code repository for the submitted tag, I am not able to see the submitted files, it is showing older files and no recently added file is being uploaded in the repo. I am doubtful on whether my solution is being considered or not.

Please reply. @Shivam

The hint is in the bit about git pull. Have a look whether there’s something (e.g. edits) in the repository in GitLab. This might have happened, if e.g. the AI crowd team edited your repository in GitLab.

I have tried the “git pull --rebase --autostash origin master” command to refresh the repo at my end, however, it is still showing the same error.

Hi @devsahu

Can you post the outputs of git log and git status?

Here is log

From this, I see that the default score is being calculated and it is not coming from my submitted solution.

Hi @devsahu,

Sorry for the confusion. Can you run git log and git status commands while inside your repository’s directory and post their outputs?

Here is the git log image

and the status output

@devsahu, Can you try running the following in your repository’s directory and let us know if it works? In case it fails again, can you post the error that you get?

git add --all
git commit -m "<Your commit message>"
./ <solution tag>