Submission failed(pack exceeds maximum allowed size)

I ran into this error when I was submitting my code. I’ve tried resetting git, reinstalling lfs, clearing my local repository cache, and the corrections given to others by the official folks @yilun_jin at Git package upload fails, but unfortunately none of them worked. Now even if I don’t commit my large model files, the error will still be there. :< Can anyone give a little tip please? thanks!!!

In the meantime, @yilun_jin please take a look for me and I look forward to your valuable suggestions!

Have you tried deleting the repo, forking again from the starter kit, and submitting again? In most cases this will solve the issue.

I’ve tried this method and it still doesn’t work. Also, I’m handing it in to my own warehouse, is it only possible to hand it in to the captain’s repo after teaming up?

Not really. Normally you should be able to submit via any team member’s repo.

Tagging @aicrowd-bot to see whether there is some error in the repo size limit. From then on, it is beyond my capability and I cannot assist any further. Sorry.

Ok, Anyway thanks for taking time out of your busy schedule to answer my questions, thanks! :>

@aicrowd-bot Hello, can you please help me with this issue, is it my repository size limit that is causing the commit to fail?

Reply myself, I have resolved the issue. If you encounter this problem, in addition to the methods I have mentioned above, you can also try the following methods. The specific solution is as follows:

  1. Create a new folder. The new folder must have a different name from the old one.
  2. Configure LFS and set up the large files that need to be tracked.
  3. First, run git add .gitattributes, and then perform subsequent operations.

Good luck, and feel free to ask me if you have any questions! :>

1 Like

Thank you for your update and good suggestions!