Submission error: " [bt] (6) /usr"

I even tried re-submitting a collab that was successfully scored and I got this error. I am using xgboost. I noticed that the package was updated yesterday in CRAN, maybe it is just coincidence?

1 Like

Thanks for your answer. I am also using xgboost. And trying several things it works in the notebook but it gives an error when uploading the submission.

It could be what you comment on the xgboost update… Let’s see if the organizers can clarify us.

I tried replacing install.packages(“xgboost”) by

packagexg <- ""
install.packages(packagexg, repos=NULL, type="source")

Without sucess. The subsmission still produced the same error


I am also getting the same error and yes I am also using xgboost. Waiting for the admins to shed more light on this.

1 Like

This is the complete traceback

Error in doTryCatch(return(expr), name, parentenv, handler) :
  [19:41:42] ./include/xgboost/json.h:65: Invalid cast, from Null to Array
Stack trace:
  [bt] (0) /usr/local/lib/R/site-library/xgboost/libs/ [0x7f57182fbdf3]
  [bt] (1) /usr/local/lib/R/site-library/xgboost/libs/ const* xgboost::Cast<xgboost::JsonArray const, xgboost::Value>(xgboost::Value*)+0x25c) [0x7f571839105c]
  [bt] (2) /usr/local/lib/R/site-library/xgboost/libs/ const&)+0x3ab) [0x7f57183204bb]
  [bt] (3) /usr/local/lib/R/site-library/xgboost/libs/ const&)+0x3d9) [0x7f571831fc89]
  [bt] (4) /usr/local/lib/R/site-library/xgboost/libs/ const&)+0x183) [0x7f571831ffe3]
  [bt] (5) /usr/local/lib/R/site-library/xgboost/libs/ const&)+0x4d1) [0x7f57183e5a81]
  [bt] (6) /usr

Hi, @jyotish
Looks like it’s not the first time this error pops up. Do you know if/how it was fixed last time?
Last time discussion

Hi @jocelyn

I believe we are in the process of provide private trace back on your submissions that will involve the full information.

This particular error you can see is due to an array casting issue from the code side rather than ours.

Once we are able to give you the private traces you would be able to immediately see the issues and self diagnose :slight_smile:


Isn’t it weird that it happens with 4-5 of us on the same day and we’re all using xgboost?

It is a little surprising indeed and we are investigating why it’s happening to make sure it’s nothing systemic.

Apologies for the delay, but now I’ve dug a little deeper (submission #113079 by @RHG) and it seems that this is related to loading and saving xgboost models.

The correct way to save and load these models is using the internal functions for the library:

  1. To save a model
  2. To load a model

Could you all please ensure that this is how your models are being saved and loaded? The issue might be fixed if we do that.

1 Like

It looks like me and RHG are running into a new problem with the error messages:

my submission message:
" [bt] (7) /usr/lib/R/lib/ [0x7"

his message: ( just truncated)
" [bt] (7) /usr/lib/R/lib/"

I’m not strong enough at the inner workings to debug from that, some googling led me to find something with the xgb.DMatrix but it hasn’t led to a solution for me after changing my code a bit. I save and load my xgb with the xgb.load and

Hi @alfarzan, thanks for your answer.

I have tried submission number 113154 again following your advice to save and load the model. The notebook works for me but on the platform it gives me the error “[bt] (7) /usr/lib/R/lib/”, as @MakePredict said.

From what I have been able to read it seems an error related to the need to install something additional, but I don’t know what it could be.

I remember that in this same chat @MakePredict commented that a notebook with which he made a correct submission no longer works for him.

Any idea what may be happening?

Thanks in advance.

Hi @jyotish, I saw this same error related with the user @jeremiedb in the chat named "Tips on creating a successful submission. How was this problem solved?

I think I have understood that it is solved by installing by default the xgboost package among others. So I don’t know why it doesn’t work now.

Thanks in advance.

Hi all,

I can confirm the errors mentioned above, I got the exact same errors with my xgboost models (which were submitted successfully last week):

  • xgboost models get " [bt] (6) /usr" error with the default save function.
  • After updating the save function with and xgb.load(), I got " [bt] (7) /usr/lib/R/lib/ [0x" error


1 Like


It seems clear that it is a platform issue with the xgboost package.

Waiting administrators will shed more light on this problem.

It looks like a tough nut to crack on their end because they might have to dig into the xgboost code to figure it out.

Yes, just letting you know that we’re still looking into a global solution for this.

It seems to be related with how xgboost is installed.

Please stay tuned :slight_smile:


Ok, so I did more experimenting. It looks like I was able to successfully send my submission by doing 3 things:

  1. Completely reset the colab notebook using restart runtime under the runtime menu.
  2. Using the trick above to install version of XGBoost
  3. Use save() and load() instead of and xgb.load()

Hope it can help


I got this for some reason:

Warning message in install.packages(packagexg, repos = NULL, type = “source”):
“installation of package ‘/tmp/RtmpM5IgIf/downloaded_packages/xgboost_1.2.0.1.tar.gz’ had non-zero exit status”

Hello everyone,

Yesterday, @jocelyn 's proposed solution worked for me.

Regarding your problem @MakePredict. In a first attempt I ran into the same error as you. My solution was to open a new notebook installing the xgboost package as @jocelyn recommended.

Let me know if work for you.


I got it working now. I did as you said.