Submission Dir Structure/Files

#1

Hi all, new to all this and trying to make my first submission. Have made it through the starter kit, trained an agent using dopamine and now have a local repository with the 5 latest checkpoints, the env, etc… I’m wondering exactly what needs to make it up to the Gitlab repository I created and how it is ideally structured. For instance, on my local machine, the checkpoints are in a dopamine/tmp/dopamine directory - I’m guessing only the last checkpoint is required, but that folder contains a lot of other files (.meta.index, sum_tree, store_reward) etc…

Currently hitting the issue regarding “pack exceeds maximum size” and understand I have to use git-lfs to solve that, but I’m pretty fuzzy on how these things all work together and am hoping someone can clarify/point me to some info that might explain the submission process better for someone new to this.

Thanks.

0 Likes

#2

I had problems with Git LFS working and I just followed this guide and created an entirely new repo on gitlab and the large files uploaded.

0 Likes

#3

The problem I’m currently running into is the actual folder structure of the submission to correctly execute.

I am currently receiving an error during submission:

2019-04-28T16:27:12.67245541Z bash: /home/aicrowd/run.sh: No such file or directory

So should we have the run.sh file in:

<.your project root folder.>/home/aicrowd/

Or is home regarded the same as root?:

<.your project root folder.>/aicrowd/

I copied run.sh in both places and the same error is being thrown, so I’m not sure what to try next.

0 Likes

#4

Putting everything in the root of your project repo is the way to go. I overthought it. The steps they list are confusing, just put run.sh in the most top part of your repository

0 Likes

#5

Thanks, appreciate it. I almost got the git-lfs working - but I get a notice that the remote host closes a few hundred MB before the checkpoint file finishes and when it does I then get an access error (it’s 4.6GB). Did you happen to run into that problem too?

0 Likes

#6

Yes. I run into that problem too, even using Tower to push, which solved my initial LFS problems. I’m not sure how to push. This is the error I JUST got once again:

Pushing to git@gitlab.aicrowd.com:HappySlice/submission-tower-challenge.git
Connection to gitlab.aicrowd.com closed by remote host.
batch response: Authentication required: Authorization error: http://gitlab.aicrowd.com/HappySlice/submission-tower-challenge.git/info/lfs/objects/batch
Check that you have proper access to the repository
error: failed to push some refs to ‘git@gitlab.aicrowd.com:HappySlice/submission-tower-challenge.git’

0 Likes