How to identify if my program running successfuly?

#1

Hi team,
@kelleni2 @mohanty @shivam

I know that we have commnad for submission
./submission.sh 1

I believe this refers to the file predict.py and runs at backedn to create the final submissions.

Now let us assume if this predict.py has some error and we do a submission. How do we know if this has run with error beucase once you run in submission it is not giving any error message in terminal. How to identify the errors? Any debug method? to know location of error in code and any other pointers which it dispalys error message.

Thanks
Shravan

#2

@kelleni2 @shivam Can you please reply to this?

#3

Hi @shravankoninti,

We provide feedback for all the submissions via Gitlab issues.

To clarify, the exact flow is as follows:

  1. You make changes to your code, followed by git commit
  2. ./submission.sh <xyz> to create a new git tag and push it to the repository
  3. We create a new Gitlab issue in your repository when your submission tag is correct i.e. prefix of the Gitlab tag is submission- (prefix thing happen automatically in submission.sh for Novartis challenge)

Gitlab Issues Page: https://gitlab.aicrowd.com/shravankoninti/dsai-challenge-solution/issues

In case to run locally, you can simply call ./run.sh on your local system and it mimics what will happen on online server (except the runtime environment). When ran in online environment i.e. as a submissions we provide feedback via sharing logs, you can read more about it here.

#4

@shivam Thanks very much for the clear explanation.

For the Submission Received #25991.
I see that imagebuildsuccessfully but failed evaluation.
Can you please let me know which is leading to failed evaluation - at what part of the code? Any debug mode available ? to check my code myself.

Please let me know .

#5

Hi,

Logs shared for both #25991 and #25990.

Please check out this FAQ for debug mode which will speed up your debugging. Meanwhile also try running ./run.sh in local system (workspace) before submitting, to catch bugs without even making a submission (as submissions/day are limited).

#6

Hi @shivam,

I see an error when am submitting to the environment. but when i ran it locally it provided me predictions. #25998

Here is the error on log issue:
2019-11-30T09:24:10.376970299Z Traceback (most recent call last):
2019-11-30T09:24:10.376999401Z File “predict.py”, line 30, in
2019-11-30T09:24:10.377004301Z import xgboost as xgb
2019-11-30T09:24:10.377008101Z ModuleNotFoundError: No module named ‘xgboost’

I installed locally these packages xgboost , lightgbm, catboost by
pip install xgboost --user
pip install lightgbm --user
pip install catboost --user

my belief is that the above packages are not updated in the environment i think. Can you please update from your side.

to update in environment I did this below
conda env export --no-build>environment.yml

(but I do not think the environment.yml is updated).

Please reply me ASAP.

#8

Hi,

I don’t see pip packages in your environment.yml. Please make sure you have activated your conda environment when you did pip install.

Output from below commands will be useful to know more about the issue you are facing.

  • which pip
  • pip freeze
#9

Hi @shivam,

I tried different methods to make sure the above packages get appear in environment.yml but in vain.

Please help me the process on who to install these packages.

  1. catboost
  2. lightgbm
  3. xgboost.

Please provide me steps. Yes I have activated conda environment. I am assuming (base) appearing in terminal is a sign for conda activation.

I tried to installl packages like conda install xgboost but it says I dont have permissions. Please help me.

#10

Hi, looks like your conda installation have permission issues. Can you get in touch with Aridhia team for permission fix along with above message?

And you haven’t shared output of above two commands by which I can check if your pip install [...] worked properly or not.

#11

Here you got for “which pip”

for “pip freeze”

Please help. @shivam

I just need the above 3 packages in the Environment.yml file. Let me know the steps to get there!

#12

@shivam Any thoughts on this how to resolve this issue. Please see above posts!

#13

Hi @shravankoninti,

Thanks for sharing the output. The pip package installation looks correct on your side.

I am suspecting pip version to be 18.X on similar on your side which isn’t working out well with conda. (Github Issue)

Can you share output of pip -V and also at the same time try installing pip version 10.X by conda install pip=10 . The exports so generated should contain all of your pip packages as well.

Let me know if this resolves the issue you are facing.

#14

Here the output is -

What next I should do?

#15

Hi, as I mentioned earlier you will need to get in touch with Aridhia first on Microsoft Teams to get your conda working i.e. fixing permission issue above.

After this, conda install pip=10 should resolve this issue. If not, we can debug further.

#16

Hi, I just remembered that participants were having sudo in their workspace. Can you instead try running the sudo chown... command yourself on workspace? I believe it will fix the permission issue for you, followed by pip=10 installation.

#17

Hi @shivam Shivam,

I dont think this is helping me much. I believe Aridhia team has to give me access.

Any suggestions? I dropped an email to Aridhia team - no reply so far…will wait for somemore time

#18

Hi, please copy paste the exact command from error message. You have to give permission for .conda folder not anaconda3.

#19

@shivam,

I dont think the path it is specifying is not available. This is what I have.

image

So I used.

I still tried - this path given above - but no use.


Any other options you see?

#20

Hi @shivam

Aridhia team seems to be clueless on how to resolve or troubleshoot. They are just giving us the readme link and check the error. It is so strange they are not able to do this.

As an alternative:
Can I open the environment.yml manually and update the packages ? This is what I have done.

image

image

image

I dont think this is working. This is the error I got in AICrowd issues log.

image

What other options?

#21

@shivam

Can you please let me know why this submitted issue gave an error.