GOOGLE CLOUD trouble running the simulator

Hey, having some difficulty running the simulator on google’s cloud. I am using a machine with 16vcpus and 64 GB of memory, but I am getting this error following AIcrowd’s instructions to get it running on cloud services.

e ‘en’ localization will be used.
[2022.01.12-00.51.29:451][ 0]LogHAL: Warning: Splash screen image not found.
[2022.01.12-00.51.29:456][ 0]LogSlate: New Slate User Created. User Index 0, Is Virtual User: 0
[2022.01.12-00.51.29:456][ 0]LogSlate: Slate User Registered. User Index 0, Is Virtual User: 0
[2022.01.12-00.51.29:461][ 0]LogInit: Using SDL_WINDOW_OPENGL
[2022.01.12-00.51.29:466][ 0]LogLinux: Warning: MessageBox: Warning: OpenGL is deprecated, please use Vulkan.: M
[2022.01.12-00.51.29:470][ 0]LogLinux: Warning: MessageBox: Unable to dynamically load libGL. SDL error: “Could
not initialize OpenGL / GLES library”: Insufficient drivers or hardware:

1 Like

It looks like your system does not have/start OpenGL. Can you confirm that you have it and send a log? Additionally, does the instance youre running on Google Cloud have a GPU

1 Like

I was using the E2 series of bots thinking that they were the same as the program called AWS E2. It was late at night… Made that assumption.
I tried getting google cloud to give me gpu access, but most areas I tried did not have gpu access or I did not have the required permission. Even then, the required memory required for this competition was over 100 Gb for this competition. Most of the vm markets did not have that either.