Git Clone Runs infinitely

I use colab to push code with git to gitlab, but recently i’m unable to do a git clone of my repository.
Please how can this be solved?

I am also getting 504 errors since some days ago, when pushing from Colab or from local.

Hi, I am also getting the same error. @dipam what do you think the problem might be? I can commit and pull my repo but the problem occurs when I submit my solution.

It seems like, I get 504 errors in this step (lines 82-83):

  git push -f $REMOTE master
  git push -f $REMOTE "submission-$TAG"

I was able to submit by following the same steps as the script but from gitlab’s browser interface:

  • Edit a file
  • Commit or merge to master
  • Tag the latest commit following this format: submission-{user}-{unique-tag}
1 Like

Thank you, your solution works.

I also regenerated an SSH key pair but that didn’t help.

So It seems like as long as we generate a tag in the format you mention we trigger the submission workflow.

Yes, I think as long as the tag starts with submission- it will trigger the workflow.

git add *
git commit -m "commit message"
git tag submission-tag
git push origin submission-tag

should work too.

Hi Everyone,

We’re looking into what’s wrong with the submission script. In the meantime, please use the advice from @hca97. The same is also described in the starter kit. Please note the you need to push to the correct remote repo. I think for most participants, this would be set to aicrowd instead of origin, please check the name of your remote repo using git remote -v before trying to push the tag.