Downloading data via AIcrowd CLI

I just tried downloading the data through AIcrowd CLI. I found two things that could be updated.

  1. It seems the link with the reference for AIcrowd CLI doesn’t work (https://pypi.org/projects/aicrowd-cli)
  2. The command to download the data didn’t work for me, a command that worked for me: aicrowd dataset download -c esci-challenge-for-improving-product-search (dataset instead of datasets)
1 Like

Hi @HAGE2000,

Thank you so much for sharing this. We have updated the commands on the resources page with your feedback.

Regards

Thanks for the quick update!

On another note, I noticed the output in the sample submission for task 1 doesn’t seem to correspond with the suggested output in the “Overview” page. I assume the format of the data on the overview page is correct with query_id in the first column and product_id in the second column?

Hi @HAGE2000 ,

Sorry for the confusion. The ordering of the columns technically doesn’t matter. In future releases of the data, we will make sure to ensure the consistency between the released data and the description in the Overview.

Best,
Mohanty

1 Like

when I run the following command:

aicrowd dataset download -c esci-challenge-for-improving-product-search

I end up getting task1 and task 2 rewritten by task 3 zip files, can we potentially make their names unique ?