Download datasets to Kaggle

How do I download the dataset to kaggle without downloading it to my local machine and then uploading it.
When I tried with wget command, kaggle returns

Resolving datasets.aicrowd.com (datasets.aicrowd.com)... failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘datasets.aicrowd.com’

Hi @phileinsopsho,

Thanks to notify, we are looking into it.

Hi @phileinsopsho,

It seems to be working properly.

Is the problem only occurring when you download in Kaggle or happening on your system too?

the wget link is working fine on my local machine, but the issue occurs on kaggle.
recently i tried the following command,

!wget -q https://datasets.aicrowd.com/default/aicrowd-practice-challenges/public/snake/v0.1/train.zip

But i got the same errors as mentioned above in the query statement.
And when I try to upload data through url, using the following link

https://datasets.aicrowd.com/default/aicrowd-practice-challenges/public/snake/v0.1/train.zip

kaggle is unable to locate any file at that link

Hi @phileinsophos ,

On Kaggle Kernels, it looks like you need to enable internet access to download external files.
Reference Link: https://www.kaggle.com/product-feedback/63544

If this still does not work, I will encourage you to try out Google Colab i.e. “Execute in Colab” button in baselines. :smile:

Cheers,
Shivam

Thank-you.
The problem has been solved.