Docker Not Running Environment

#1

I built the docker image in the obstacle-tower-challenge folder. When I run the docker code provided for ./run.sh, the agent correctly starts.

obstacle-tower-challenge davoo$ docker run   --env OTC_EVALUATION_ENABLED=true   --network=host   -it obstacle_tower_challenge:latest ./run.sh
root
INFO:mlagents_envs:Start training by pressing the Play button in the Unity Editor.

When I run this command to start the environment
docker run --env OTC_EVALUATION_ENABLED=true --env OTC_DEMO_EVALUATION=true --network=host -it obstacle_tower_challenge:latest ./env.sh
It just spits out what the console would spit out if I were to run env.sh then the console goes back to accepting input and the agent times out waiting for the Unity Editor to start.
`+ ENV_PORT=

  • ENV_FILENAME=
  • ‘[’ -z ‘’ ‘]’
  • ENV_PORT=5005
  • ‘[’ -z ‘’ ‘]’
  • ENV_FILENAME=./ObstacleTower/obstacletower.x86_64
  • touch otc_out.json
  • APP_PID=10
  • xvfb-run --auto-servernum ‘–server-args=-screen 0 640x480x24’ ./ObstacleTower/obstacletower.x86_64 --port 5005 2
  • TAIL_PID=11
  • wait 10
  • tail -f otc_out.json`

I have no experience with docker. Any tips? Thanks.

1 Like