Docker container reading my AI python script

I seem to be lost, I’m trying to get my Ai to run on the nle game docker container. I have been able to get the docker container to run fine, winpty docker run -it fairnle/nle-focal python -m -e NetHackChallenge-v0 boots up the game. Also my algorithm works fine on it’s own, as far as I can tell, although it yells at me for trying to import gym, and nle, which I can’t really do. The issue is when I try and do something like winpty docker run -it fairnle/nle-focal python it tells me that

python: can’t open file ‘’: [Errno 2] No such file or directory (base).

Whenever I attempt to run it I always cd to wherever I’ve actually put the file, but I don’t think it is even looking there. When inspecting the dockerfile for FN/N-F I find that it seems to point to using the directories opt/conda/bin which I believe is a Linux directory thing (not entirely sure). I can’t seem to find those directories to even put the file in, and when I tried to create the directories, and even go as far as to add the path that is shown in the inspection it still can’t find the file. I’m attempting to run this on windows 10 and theoretically it should work because it’s a Docker container. I also have a virtual machine with an up to date Ubuntu os, and if that is the right system to use, how can I solve my problem there? Perhaps I’m over-thinking this and I feel a little silly that I can’t find the solution for the life of me, if anyone is able to help me I’d really appreciate it, and sorry if it’s a dumb question.

Really appreciate you taking the time to read this,

So after taking the time to do a bunch more research I think what I’m supposed to do is bind mount my file to the docker container. Which seems straight forward enough I pulled fairnle/nle-focal onto my host machine, I made my algorithm, and put it in it’s own directory. Then I run winpty docker run -it -v /c/Users/MyName/desktop/Ne:/opt/conda/bin fairnle/nle-focal python and as far as I can tell it should run. Unfortunately it tells me this; python: can’t open file ‘’: [Errno 2] No such file or directory. Which leads me to believe maybe, I’ve missed what the absolute path to the Docker container is but even if I substitute both paths for, $(pwd):/wd it still gives me that error. Have I missed something fundamental, or am I doing it mostly right and there’s just a little tweak I have to make for it to run? I’m not trying to be a pain, it’s just odd that I can’t seem to get docker to work for me even though it should be a fairly simple process, as far as I can tell.

As always, thank you for taking the time to read,