DDQN model submission failed

#1

Hi

I succeeded when I evaluated locally DDQN models that I trained locally.
but, If I upload to Submission, an unexplained error occurs. and all log pages are not found.
One error was written as a cuda runtime error in the comment, so it was forcefully uploaded to the cpu, but the result was the same.
I also changed the location of the model, and nothing worked.
The only time I was able to successfully submission was when I didn’t load the model.
I am very frustrated because I cannot check the error log.

If someone has uploaded a model and successfully submission, please let me know the tip.

#2

Hi @Paseul

I’m sorry to hear that your submission did not work. Using pytorch-cpu should work. I made my submission this way. I propose the following steps to resolve the issues:

  1. If you are running on a CPU-only machine, please use torch.load with map_location='cpu' to map your storages to the CPU`
  2. if this does not work. Uninstall pytorch in your conda environment. Then run the following command in your conda env conda install -c pytorch pytorch-cpu. Once this is done you have to update your environment.yml as explained in the starter kit.

Please let me know if this resolves your issues.

Best regards
Erik

#3

I actually did my submission using the cpu only installatino of pytorch. Then it should work out of the box without any changes.

#4

Hi @mlerik
I solved it by your first solution.
It should be known that the basic option is to load the model with map_location=‘cpu’ in the submission.
Anyway, I’m able to focus on the mission without worrying about the submissions.

Thank you @mlerik !!