Camera configuration on evaluation server

As I understood, we are allowed to use front-, left- and right-facing RGB cameras during the evaluation of our submissions on the remote server.

I was able to configure those observations in my local setup, but according to the logs, the evaluation environment on the remote server provides me only one camera image in obs[1], i.e. len(obs[1])==1.

How do I enable all three image observations?

1 Like

Hi @bernd_heihoff,
You are allowed to use any camera configuration for training purposes.
So you can use the cameras for pertaining and learning the weights for your model.
During the evaluation, it will only be a single camera predecided from our end that is going to be used.
So no need to worry about the evaluation portion those configs are decided from the backend.

1 Like

Hi @sidharth_kathpal6,
thank you for the clarification. I think the challenge overview is a bit misleading in that matter. In section “THE learn-to-Race Framework” it says:

During evaluation, the agents will ONLY have access to speed and RGB images from cameras placed on the front, right, and left of the vehicle.

Maybe that should be clarified as well.

Edit:

This is also stated in section “Competition Structure” / “RULES”.

It is just a bit unfortunate because our previous development had these rules in mind.

2 Likes

Could you please point out where in the rules it says that we only have one camera view during evaluation? Maybe it is the better option to change the server configuration instead of the rules. Thank you very much! :smiley:

2 Likes

Hi @bernd_heihoff,
We had a discussion among the organizing committee we will be allowing the use of three cameras for the evaluation phase for now. To add the configuration -
config.py - active_sensors = [
“CameraFrontRGB”,
]

Add names of the other cameras here in the config file.

3 Likes

Hello @sidharth_kathpal6,
thanks for the investigation!
I copied the original config.py file to be sure and modified the according part. However, the environment still seems to only give me one image. Is it possible that the change does not work yet?

1 Like