Web browser & Jupyter-lab in linux virtual machine?

Hi Team,
I am not able to see webbrowser in the linux machine.
I tried using jupyter-lab. here is the screen shot it says no webbrowser ? Please help how to launch jupyetr lab.

I think you should be able to use the link provided in the pre-installed Firefox to access jupyter-lab. No idea why your machine thinks you don’t have a browser though…

1 Like

Weird behavior indeed.

@nrad might be able to help.

Until then, I see at the bottom of your screenshot, it gives you the url to use.
Have you tried entering manually the url in Firefox that is pre-installed on the Linux VM?

1 Like

How can I check the firefox pre-installed . I cannot find. Can you take a screenshot and show me how to launch firefox?

THis is my machine. Where to browse for firefox?

Can you try this:

And then type firefox ?


I am suprised to see this that there is not “applications” option.
what I have is

Hello @shravan.koninti

It looks like your xfce config is a bit messed up due to which the top navigation bar and the bottom applications bar seems to be missing.

To start firefox, you can try the following

  1. Open the terminal
  2. Type firefox and hit enter

If you see an error saying firefox is not available, you can install it using sudo apt update && sudo apt install -y firefox.

1 Like

Looks like we can’t see your bar at the top.

Let’s try this instead, … in the blue-greenish background, right click.

Do you have a menu showing up?

Applications >> Run Program


And to fix your top and bottom bars, you can do the following

  1. Open terminal and run the following

    rm -rf ~/.config/xfce4
  2. Stop and start the workspace.

  3. Click on the “Use default config” option when you restart your VM.

Yes I am able to do this. Thanks.
But how to copy text from terminal to webbrowser? ctrl+C is not wortking and right click also not working

That panel window is not displaying.

I am copying text of jupyer lab link in browser. how to do?

I’m realizing that the terminal screenshot you first provided, was from the Terminal outside of the desktop.

Have you tried typing:


from within the Terminal Emulator that is in the VM desktop? (Right underneath Run Program in my recent screenshot)

Hi shravan.koninti,

I have tried this and for me selecting link text in the terminal with a mouse, right click and copy worked.


Hi Michael,

Very good observation. I missed this fact. Thanks for that.


Yes you are right. The terminal is from outside. Now I opened terminal from VM and I installed again. let me check agian. Thanks

Its working now . Thanks. @jyotish Question: what all websites we have access to? I want to copy some reusable codes from google/stackoverflow etc…

Internet connectivity is ultra limited.
You won’t have access to those typical resources (google, stackoverflow, etc…)
Here’s a list of the allowed domains.

However, you can copy your local clipboard to your remote clipboard. See instructions here.