Submission script error


I’ve followed the instructions to submit a model and I get the following error. It’s like my model weights file is too large even with git lfs? It’s just around 200MB. I’ve tried with both HTTPS and SSH but same problem.

Is that expected it’s using ‘mosquitoalert-2023-phase2-starter-kit’ repo (hard coded in even if my project is named differently (during the fork)? create the additional repo where I’ve no code.

python local evaluation works fine.

./ 'Test'
Making submission as "MYACCOUNT"
Checking git remote settings...
Using as the submission repository
Updated git hooks.
Git LFS initialized.
[master b69368d] Changes for submission-Test
 1 file changed, 0 insertions(+), 0 deletions(-)
 rewrite my_models/MYMODEL/weights/best_model.pth (99%)
Uploading LFS objects: 100% (2/2), 232 MB | 1.1 MB/s, done.
Enumerating objects: 372, done.
Counting objects: 100% (372/372), done.
Delta compression using up to 20 threads
Compressing objects: 100% (313/313), done.
Writing objects: 100% (372/372), 205.95 MiB | 15.85 MiB/s, done.
Total 372 (delta 94), reused 203 (delta 49)
remote: fatal: pack exceeds maximum allowed size
error: remote unpack failed: index-pack abnormal exit
 ! [remote rejected] master -> master (unpacker error)
error: failed to push some refs to ''

Thanks for any help.

BTW: I’ve tried to force to my gitlab project but I’ve exactly the same error:

git remote remove aicrowd
git remote add aicrowd
./ 'Test'

Also checked:


No luck.

When I run git lfs ls-files comannd I can see my model but it fails on git push:

0f11b1dd84 * my_models/yolo_model_weights/
b36d4aa091 * my_models/MYMODEL/weights/best_model.pth

the only change is the addition of best_model.pth file, previous push was working.

my .gitattributes:

*.pth filter=lfs diff=lfs merge=lfs -text
*.pt filter=lfs diff=lfs merge=lfs -text

Answering to myself.

I’ve started again from scratch without modifying projet name when forking and carefully install git lfs before any commit and track all pt and pth files:

git lfs install
git lfs track "*.pt"
git lfs track "*.pth"
git add .gitattributes

And make sure that:
git remote add aicrowd

Then I added/commited my large model file:
git push aicrowd master

And it worked in GitLab. I’ve created submission manually with tag option and not with submit script.