Submission not showing up

After I created a tag and push to my repo in gitlab, there is no new issue being created in my repo. This exact same process worked for my last submission, but it did not work this time. Is there something I am not aware of?

Hi @yankeesong, the submission is valid only when:

  1. tag starts with prefix submission-
  2. the tag commit hash is new and not same as any previous submission, i.e. 2 submission with same commit is ignored

I think your tag push isn’t considered for submission due to 1st point above.

Hi @shivam, thank you for the help.
Now I have successfully made a submission. However, it has an evaluation error, with the following error message:
The following containers terminated prematurely. : agent
Please contact administrators, or refer to the execution logs.
Could you please help me with this?

Hi @yankeesong,

It is because matplotlib is not installed in your current runtime environment.

You can do so by adding it in your environment.yml file. In case you are an advanced linux user, and want to see all the ways you can configure runtime environment, you can read this FAQ post.

You can view the logs for debug submissions (i.e. debug: true, in aicrowd.json) yourself by clicking on link present in your GitLab issue. Something like below:

:bulb: Logs for Admin Reference : agent-logs | pod_spec-logs | error_trace-logs |

Let me know in case you have any follow up question.

Hi @shivam,

Thanks! However, after I have modified my environment.yml file, I still get an error in my submission, with an error message I cannot understand. Sorry to ask for so much help. I’m not very familiar with linux.

Hi @shivam,

I submitted again and encountered the same issue here:
I’m not an advanced linux user and I cannot make sense of this error. Could you please help me out?
Thanks fo much!