Submission error

Can you please help me with the error?

I have run the cell containing the code

‘!pip install -q -U aicrowd-cli’. Restarted my kernel too.

Hello @thanish

Can you tell us which OS you are on?

I am also having issues while making submission. can you help me in this?

I am using Windows Vm and python

Hello @aman_patkar

Can you try replacing the following

!aicrowd notebook submit \
    --assets-dir $AICROWD_ASSETS_DIR \
    --challenge addi-alzheimers-detection-challenge


!aicrowd notebook submit \
    --assets-dir $AICROWD_ASSETS_DIR \
    --challenge addi-alzheimers-detection-challenge

and let me know if it works?

1 Like

it is also making error but of different kind.

This is the end of the error.

This is what i changed as per my requirement.

I’m using Linux machine

@thanish Can you verify if aicrowd-cli package is installed? You can install it using pip install -U aicrowd-cli command.

when run the command as it is I get this error
!pip install -q -U aicrowd-cli

“/bin/sh: 1: pip: not found”

So I changed it to pip3 as below and the installation went fine
!pip3 install -q -U aicrowd-cli

I am using Windows Vm

Issue is still not solved…

@jyotish : Any update on this?

@aman_patkar Can you re-install aicrowd-cli and try again?

pip install -U aicrowd-cli

We made a few changes to handle the errors you were getting.

@thanish This looks more like an issue with the way python is installed. If you are still facing the same issue, that means that the python being used by your notebook is different from the the python using which aicrowd-cli was installed.

Are you using some version of conda to manage python?

I installed jupyter by sudo apt install jupyter.
If that is wrong can you point me to some document on how to remove all of it and reinstall as recommended?

@thanish This worked for me.

  1. Exit jupyter
  2. On your terminal, run echo 'export PATH=$PATH:$HOME/.local/bin' >> ~/.bashrc
  3. Restart terminal or run exec bash
  4. Start jupyter

Why do you need to do this?

It looks like pip3 that comes with the OS installs everything to ~/.local and ~/.local/bin is not part of the system path which was leading to aicrowd not found kind of errors.

We recommend using anaconda/miniconda to manage python versions as it takes care of most of such issues. However, as long as things work the other way, I think it should be good. :slight_smile:

@jyotish. Thanks that worked. But when I submit I’m getting this error. Can you help me why it is a read only?

1 Like

@thanish It looks like the path in AICROWD_ASSETS_DIR is pointing to a read only file system. Can you check if you are able to create files/directories from the directory in which you started jupyter?

1 Like