Submission error

I am having this issue while submittng/

Hello @thanish, this looks like a bug on our end :sweat_smile:. As a temporary workaround, can you start jupyter notebook inside /home/desktop0/comp/ directory and try again?

It should be something like

cd /home/desktop0/comp

We will patch the bug as soon as possible.

1 Like

That worked. Thanks :slight_smile: Made my first Random submission :smiley:


Hello @aman_patkar

Do you have multiple instances of jupyter notebook running? Can you stop any additional jupyter notebook servers you started and try again?

This error is displayed when there is no active notebook on jupyter. We consider the jupyter session that was last started and take the active notebook with the most recent changes.

1 Like

I checked and it is only single notebook in which i am makiing submission.ty

Hello @aman_patkar

The screenshot you shared gives list of notebooks/terminals running in the current jupyter server. You can run jupyter-notebook list to get a list of active jupyter servers.

hello everyone!

I’m using linux VM, and have troubles with submission.
my steps:

  1. launch jupyter lab inside my working folder:

  2. specify path variables as follows:

  3. submit:

  4. however submission fails:

long error log in details, and: what do I do if I have this file:

Hi @tymur_prorochenko,

The error is because you have hard coded the AICROWD_DATASET_PATH and other similar variable. Please use environment variable to specify the path of the files. You can use the below code to make your submission work.

AICROWD_DATASET_PATH = os.getenv("DATASET_PATH", "/home/desktop0/competition/validation.csv")
AICROWD_PREDICTIONS_PATH = os.getenv("PREDICTIONS_PATH", "/home/desktop0/competition/prediction.csv")



Thank you, @ashivani ! This did help, and I made several successful submissions.

Now I have another problem and I wonder if you could maybe point where to search for the problem.
I’m getting AttributeError: '_name_of_the_model' object has no attribute 'classes_' during the inference stage. This error may happen if the classifier is not fit, however it is strange since the notebook works fine before submission, and the model is loaded from assets.

Hello @tymur_prorochenko

Based on the discussion from this thread this happens when there is a mismatch in the versions of scikit-learn, numpy used to save and load the models.

Can you try adding -U flag in your pip install command (so that the packages used on the evaluation image are upgraded instead of getting skipped)?

For example

!pip install -U numpy scikit-learn

It would be good to pin the versions as well if you can so that the exact same version of the packages are used during evaluation for your submission.


@jyotish or @ashivani I am having submission error. I am using linnux VM.
This is the place where I am running my python files.

Here are the paths.

The error is

Please help!

Hi @shravan.koninti

I have shared the fix over private message.


what private message? I did not get this!

Sorry, I realized that the bug was not yet fixed, but continuing it over to the private message.

Hi @ashivani @jyotish ,

I get the following submission error, windows VM.


How to solve?

I have the same problem -

Please let me know how to resolve. Thanks.

Hi @shravan.koninti, I’m having the exact same error of “Operation not permitted” when copying the assets directory, have you solved it by any chance?

Many thanks,

Yes it got resolved. The organizers team has helped me

1 Like

Ok, perfect thanks!

Dear @ashivani, could you help me solve the issue as well or share the solution?


@giulia_cantini I hope you issue got resolved.

For anyone facing a similar issue, the issue with the permissions of the /files directory. This directory is owned by root, and hence aicrowd-cli cannot read files in the directory.

To resolve the issue, please move your files to any place other than /files , and things will work perfectly fine.