Starter kit stuck "pending" state for a day

Hi there, I am having trouble with my pod being stuck the in “pending” state. My submission was just the starter kit without any modifications.

Here’s a link to the issue: and here’s aicrowd-bot says

##### Pod Health :heart:
- *Pod State* : `Pending`
- *Pod Scheduling Time* :clock1: : `26150 secs`

- *Containers Waiting* :large_orange_diamond: : `redis-server`,`aicrowd-subcontractor`

Thank you!

Hi @felixlaumon,
I have responded on the relevant issue.
We had some issues with the compute cluster used for the evaluation, and this submission fell through the cracks when doing some maintenance.
This will be requeued.

Update : The evaluation has been successfully completed now.

Hi @mohanty, it appears my new submission it’s stuck at pending evaluation. It seems the error message this time was something to do with timeout with Gitlab.

Another question do you know if failed evaluation counts towards the 100 submission quotas?

Requeued the submission.

Hi @mohanty I think I have isolated the problem to enabling GPU during evaluation. I made a new submission (issue #10) based off the obstacle-tower-challenge master from GitHub and the only modification is in aicrowd.json having gpu: true.

Is GPU not supported during evaluation or is this a bug? Let me know if you need more details in reproducing this issue.

Thank you!

Hi @felixlaumon,

Hey, yes, we also figure out some issues with the GPU configuration on the cluster, and have since fixed it. and requeued both your submissions which were stuck.

Sorry for the inconvenience.


@mohanty That’s good news. But it seems I have used up my quota today just to test out the submission :sob: Is it possible to reset my quota for today? Thanks!

Sorry saw the message only now.
But can you try now ?

I just tried now. I am still getting this error:

 Submission failed : The participant has no submission slots remaining for today.

@felixlaumon: I deleted all your failed submissions. It has to work now !

Hi @mohanty unfortunately my last submission from last week was still failing. Can you please take a look at the issue

It’s working in my local machine but the submission somehow failed. Thank you!

@felixlaumon: I pasted the logs. But looks like its the timeout exception again (even if I see that you have a 10 min timeout set in your code). This might need a closer look from @arthurj , @harperj and @anhad

@mohanty So I have finally successfully made my first submission (that is not a random agent)! :tada:

The one important change I made is to defer importing RainbowAgent and tensorflow. See this commit here The evaluation ran successfully after this change.

I suspect that you guys might have a race condition when the agent ( and the environment ( are launched in docker. Importing RainbowAgent and tensorflow usually a bit of time (like a few seconds) and they might cause to try to listen to the port first before the env is ready in

I can replicate this issue locally as I always have to wait for Start training by pressing the Play button in the Unity Editor message to show up in before I launch Otherwise the environment will time out.

You can probably replicate this issue by trying to put time.sleep(10) in the very beginning for

While deferring import works for me for now, it is not ideal. So it will be great if you guys could look into this issue. And please let me know if there is any further information you’d like me to provide.

Thank you!

1 Like

@felixlaumon: It would also be great if you can send in a pull request by adding a note about this to the gcp_training doc in the starter kit.