Simulator in WSL?

Hi, is it possible running the simulator on WSL? I am getting errors when launching the script. See logs below. (8.7 KB)

WSL is not supported. Can you use AWS? that’ll be the easiest.

1 Like

Can I run it in Docker?

So is it possible to run even on windows?

I undrstand that since it needs an Nvidia card it would be best to be used on Amazon Web services, but AWS is also extremely hard to navigate. I have tried multiple times to get something to run on those services but to no avail. Can there be a turtorial?

1 Like

Just as a follow up to all of this - you can run it on Windows.

Try to confirm the following:

  • Are you using the OpenGL version? WSL/WSL2 doesn’t support Vulkan.
  • Are you using WSL2? I’m currently using it with the NVIDIA cuda bypass, in case it matters.

Additionally - is there a way to specify the GPU for the simulator? It’s running on my integrated GPU instead of my main GPU, and I’m not too familiar with WSL2/the sim to change it otherwise. I’ve tried disabling the integrated GPU, but that leads to almost no utilization from the GPU, and instead the utilization seems to end up at the RAM/CPU level instead:




1 Like

Finally got it to work now. But I am having difficulty getting the simulator to work. Does the simulator require unreal engine? I downloaded Unreal but I am getting error

cannot access ‘/root/ArrivalSim-linux-’: No such file or directory
: /root/ArrivalSim-linux- not found

1 Like

Personally - I didn’t download unreal to get it to work. I just used the script as-is. Though I will say there are probably files trimmed from this version of the simulator, as you can’t run it with opengl3 using the options. [ If someone from the team working on this wants logs and other information regarding this I can provide, as it is what causes some problems on the VNC server side of things ]

1 Like

I was able to get the simulator to run on wsl2 ubuntu… follow to enable GUI apps

the trick is to do this export LIBGL_ALWAYS_INDIRECT=0 in your ubuntu and in for your VcxSrv startup