Repeated reward for logs and furnace

I find a bug in minerl 0.2.4. The agent is rewarded every time when the quantity of furnace or log changes from 0 to 1. For example, if I use up logs to craft planks and then chop another tree, there will be another 1.0 reward. Similarly, if I place the furnace and collect it again by breaking it, I can repeatedly get 32.0 reward.

1 Like

Deviating from your post, did you build the furnace? or was it present with you in the environment? In which environment were you trying this out?

In case you did build it: We are currently facing an issue with equipping the wooden pickaxe. Which you require to collect cobblestone, which are required to build a furnace. So, are you able to equip the wooden pickaxe?

Yes, I built it myself. In ObtainDiamond env.

Yes, I can equip the pickaxe. I checked out the other thread about the equipping bug. I also met the same bug but it is slightly different. Once I have equipped the wood_pickaxe, I could not un-equip it by performing “equip air” action.

Thanks for the reply.

We are also facing the unequip issue you mentioned.

We chop the first tree and we automatically equip the log. After this, we are unable to unequip the log. As a result, we are also not able to equip the wooden pickaxe.

Did you face this issue of equipping the log automatically? If yes, how did you uneqip it?

I rechecked just now and also faced the auto-equipping issue. But weird things happened. This time I could not equip the wooden pickaxe. I tried several times but still could not get the wooden pickaxe equipped.

Auto-equipping is a ‘feature’ of Minecraft. Items are placed in your inventory in the order that they are collected and the equipped item index starts at 0 causing your first collected item to be equipped by default. The reward for 0-1 should not be the case, we will review this asap and update MineRL

Thanks for your reply Brandon.

I understand auto-equipping. But still not clear, why I am not able to equip a pickaxe? Have you tried this out?

Try using the minecraft id for items instead of a number, e.g. equip='wooden_pickaxe'

Tried this as well with no luck :frowning: (tried “wooden_pickaxe”, “none”, “air” and “stone_pickaxe”)

Does not work with strings either.

Just to follow up here - this was indeed an issue and the fix is being bundled in minerl 0.2.5!