Problem with 1.1_windows


Traceback (most recent call last):
File “”, line 26, in
env = ObstacleTowerEnv(args.environment_filename, docker_training=args.docker_training)
File “c:\unityproj\rl\obstacle-tower-env\”, line 39, in init
self._env = UnityEnvironment(environment_filename, worker_id, docker_training=docker_training)
File “C:\ProgramData\Anaconda3\lib\site-packages\mlagents_envs\”, line 67, in init
aca_params = self.send_academy_parameters(rl_init_parameters_in)
File “C:\ProgramData\Anaconda3\lib\site-packages\mlagents_envs\”, line 493, in send_academy_parameters
return self.communicator.initialize(inputs).rl_initialization_output
File “C:\ProgramData\Anaconda3\lib\site-packages\mlagents_envs\”, line 79, in initialize
“The Unity environment took too long to respond. Make sure that :\n”
mlagents_envs.exception.UnityTimeOutException: The Unity environment took too long to respond. Make sure that :
The environment does not need user interaction to launch
The Academy and the External Brain(s) are attached to objects in the Scene
The environment and the Python interface have compatible versions.

I’ve got some error and strange image with v1.1_windows.
But, It seems to work with v1.0 that I’ve got earlier.

‘ObstacleTower-v1’ started successfully!
Unity Academy name: ObstacleTower-v1
Number of Brains: 1
Number of Training Brains : 1
Reset Parameters :
dense-reward -> 1.0
floor-number -> 0.0
tower-seed -> -1.0
Unity brain name: LearningBrain
Number of Visual Observations (per agent): 1
Vector Observation space size (per agent): 7
Number of stacked Vector Observation: 1
Vector Action space type: discrete
Vector Action space size (per agent): [3, 3, 2, 3]
Vector Action descriptions: Movement Forward/Back, Camera, Jump, Movement Left/Right
INFO:gym_unity:1 agents within environment.
Episode reward: 0.0
Episode reward: 0.0

Anyone have success with v1.1_windows?

1 Like

I got same result in Linux

Hi @proudius @Mingta,

Can you give more details about how you’re running the binary? Is it on your host, or are you running inside docker containers? Are you setting any ENV variables specifically?

In my case, I run the env on Kubernetes container by remoting SSH/Jupyter. The ENV variables set as default. any suggestion for me plz?

Windows 10,
conda 4.6.3,
Python 3.6.6,
Nothing is touched after clone except copying the binary.

Same issue here on a Win 10 desktop

My steps:

  • Clone obstacle-tower-challenge repository
  • Create conda environment (Python 3.6.8)
  • Install git
  • Install numpy 1.15.4
  • pip install -r requirements.txt
  • Download build and extract in the repository path

This issue occurs on both version of OTC (v1, v1.1)

same issue .
Windows 7
Anaconda python 3
all the requiements

Hi all,

Thanks for pointing this out. I have been able to reproduce myself, and will be working to fix this today. There weren’t many changes made to the binary between v1 and v1.1 so we should be able to isolate the change.

Hi all,

Can you try this Windows binary and let me know if it works? This resolved the issue for me locally, but I want to ensure that is the case with everyone before pushing it officially:

1 Like

That worked for me! Fixed the problem right up

work for me as well,thanks.

BTW is there a Linux version can let me try ?

The code runs now after 1.1.1 fix, but now I just have a black (blank) screen. I’m on Windows 10

also same as Joycevk said : got a a black (blank) (small) screen


Ubuntu user here. I thought the blank small screen was intentional? I also get the same screen when I use the Obstacle Tower environment.

The code runs now after 1.1.1 fix

We just need a fixed Linux build as well

Glad to hear it works for people. The black screen is intentional. By default we turn off the window rendering on order to not render extra frames when not necessary. We will be adding the ability to visualize during training though for those interested.

1 Like

Thanks for the info! good to know it’s intentional :slight_smile:

Hi all,

We’ve pushed a v1.2 release of the obstacle-tower-env which allows you to run in “real time mode” We also pushed new binaries for Windows and Linux which should address the issues people have been having:

1 Like