Not able to get starter notebook

Hi Team,

I am unable to get the starter notebook in the Aridihia Workbench. As mentioned in the description i used the following code to get the notebook but it says path does not exist as there is no such folder.

cp  /ds_share_drive/python.ipynb ~/python.ipynb

Please help me solve this.

Hello @rohithr464

Thanks for pointing this out. There was a typo. It should be

cp  /ds_shared_drive/python.ipynb ~/python.ipynb

We fixed it on the submission instructions page as well.

Hi @jyotish,

Sorry I changed it as you said, still I got same error that path does not exist.

These are the steps I followed

  1. I created windows workspace in AD workbench.
  2. Downloaded and installed Anaconda.
  3. Went to Jupiter terminal and executed the above command.

Let me know if I missed anything.

It works for Linux machine but not for Windows one.

How can i do copy in Windows?

I can see data and notebook files in linux desktop. How can i copy those to windows desktop?

Hi, on the Linux machine please copy the data you need to ‘/files’ folder and then they will be available on ‘files (Z: drive)’ for Windows machine as well.

You can copy files in two ways.

  1. On Linux Desktop: copy a file from ‘/ds_shared_drive’ to ‘/files’ using file system manager (just like you would in Windows)
  2. On Linux terminal:
    a) navigate to the share drive folder (example: ‘cd /ds_shared_drive’);
    b) copy a file to /files (example: ‘cp train.csv /files’)

Then this file is accessible form Windows machine.

Please let me know if this worked for you.


Hi, please see my reply from few minutes ago.


Thanks! So first I must start Linux machine and copy files and only then start Windows machine.

Hi, sorry but yes. But you should only need to do this once or occasionally.


I am on a Windows VM, I managed following the first steps :

  • open Linux VM to manually copy train.csv and valid.csv in the folder “files/”
  • install Anaconda
  • change proxy
  • install r packages (I would like to work with R)

But I can’t manage the next step which is to copy the starter notebook. I get the following error:

‘cp’ is not recognized as an internal or external command

Do you know what I missed?

Thank you in advance,

Hi @demarsylvain,

To download the starter notebook, you can do either of the following,

First Way

  1. Copy the starter notebook from the Linux machine to /files .
  2. In your Windows VM, open the Anaconda Prompt and run the following command
copy Z:\r.ipynb r.ipynb

Second Way

Open Anaconda Prompt and the run the following command.

curl -k --output r.ipynb

This will download the notebook in the current directory.




Please see these two posts for issue with copying files to Win machine:


1 Like

I followed the instructions of several discussions, and the first lines of code seem to work (no warning nor error). I managed to download aicrowd.R file, to download and load R libraries, load the datasets and made some explorations.

But I got an error when I tried to linked with my Aicrowd account.


running command … had status 1

I copy-paste directly from my aicrowd page, so I don’t think I made an error. Do you know what could be the problem?