KeyError: "notebook_dir" when submitting


I am getting this error when trying to submit my notebook. Sorry for the split trace, I didn’t find any better way to get it. :frowning:

Any idea why this is happening? Anyone else encountering this issue?


I’m getting the same error, using a notebook that was previously running fine.

Trying to debug this for the last couple of hours.
I might be wrong, but I have a feeling it’s related to the procedure not being able to detect our most recent notebook.
I recall a previous thread that was related to jupyter running twice in the background…

Continuing my investigation.

Hello @gaetan_ramet @michael_bordeleau

Thanks for pointing this out and sorry for the inconvenience it caused. Can you re-install aicrowd-cli and try submitting again?

pip install -U aicrowd-cli

We were working on fixing some notebook path related issues for jupyter notebook and it seems to have broken the jupyter lab. We released a new version just now that should fix this issue.


I already had this line in my notebook (with an additonal -q flag), but re-running it solved the issue

Thanks for your help!

1 Like

Hurraay, quickest turnaround ever! :muscle: