How to use furnace to "nearbySmelt" coal?

I am new to MineCraft. May I ask what the ingredients of this action are? I tried with logs and planks in inventory but nothing happens. According to the game wiki, this should produce charcoal (using planks as fuel). Thanks.

MineRL uses Malmo’s functions to make such smelting easier, essentially turning it into crafting. You only need to have iron ore and coal in your inventory, and once you do nearbySmelt iron you should get an iron ingot immediately. This was discussed on some other thread here on same channels.

Thanks for your reply but I am afraid you didn’t get my point. The minerl doc mentions an action nearbySmelt[coal] which I think means using the furnace (and some ingredients) to produce coal. And in fact, in the MineCraft game, it is possible (we can burn logs into charcoal).

Ah my bad. Indeed you should be able to burn logs into charcoal in default Minecraft but indeed the action nearbySmelt[coal] does not do anything after quick testing. It is either bugged or refers to something else (remnant of traditional smelting action?).

This has also been discussed here: How is the "reward" on leaderboard page computed? (Edit: Oh, it was you who reported this ^^’)

As Miffyli pointed out, nearbySmelt['coal'] was intended to let the agent make coal from a furnace using logs so that torches could be made using only wood and stone.
Unfortunate to hear that there is a bug with this, what are basic steps to reproduce?

I tested it like this (Ubuntu 18.04, Python 3.6, MineRL 0.2.4):

  • Create env and control agent by feeding user input
  • Focus on game, press “T” and command yourself necessary items (/give @a furnace 1, \give @a log 64 and /give @a planks 64)
  • Place furnace, face it and try to use nearbySmelt=2 (="coal"). Nothing should happen (no crafting/smelting).

Thanks for this, I will take a look. Could be a weird interaction between the Minecraft give commands and the Malmo agent, I will explore building a world with the needed resources and see if this is still the case

Tested this on Windows 10 one more time, still no luck :(.

Random thought: Perhaps it works but it creates charcoal, and since charcoal != coal it won’t show up in the inventory list? They are very distinct items in Minecraft, but I am not sure if Malmo or your code abstracts this one out.

They should have the same item-ID so this should not be an issue but I will verify this when checking it out!

1 Like