Getting started without GPU?

Hello! I’m super-excited for this competition, and huge thanks to everyone who is working so hard to prepare and host this event!

My questions all feel pretty stupid, and I appreciate your patience with me as I struggle to get started.

I’m having trouble getting going with the starter kit and running the Torchbeast starter agent. The docs seem to indicate that the Torchbeast model is built off of Polybeast, which looks like it depends on two GPU cores. My Intel Macbook Pro does not have a GPU available. Should I focus on building my submission inside Colab (if so, is there a walkthrough for how to do that?), or port the included baseline Torchbeast starter-kit away from Polybeast and into something like Monobeast (is this too much for a beginner like me to tackle?), or is there another option that I’m missing?

I guess I’m not sure how to handle the lack of GPU, and how to get all of this starter code running. I think I’m mainly confused on if I should focus on building / running my solution inside of Docker, or if I can reasonably use Colab, or if I should install things locally in my Mac.

Thank you very much!

1 Like

I believe you can run the training loop on CPU only by doing python disable_cuda=True. Does that work for you?

Thank you for the reply, @edward_grefenstette!

I’m able to execute that command, but I ran into the issues described in #11 and #12:

After resolving those, I ran into this error, and haven’t yet tracked down the cause:

  File "/Users/clintherron/anaconda3/envs/nle_challenge/lib/python3.8/multiprocessing/", line 19, in __init__
  File "/Users/clintherron/anaconda3/envs/nle_challenge/lib/python3.8/multiprocessing/", line 58, in _launch = util.spawnv_passfds(spawn.get_executable(),
  File "/Users/clintherron/anaconda3/envs/nle_challenge/lib/python3.8/multiprocessing/", line 450, in spawnv_passfds
    errpipe_read, errpipe_write = os.pipe()
OSError: [Errno 24] Too many open files

I’ll keep working through it – thank you!

I believe @roberta_raileanu ran in to this problem previously and suggested that ulimit -Sn 10000 resolved it for her!


@danielle_rothermel Running that command prior to running worked for me, thank you! :slight_smile:


A touch overdue here, but since this question was posted, prebuilt Docker images have been released as well as a sample colab for running baselines.