Problems with starter kit setup

When I try to run the command sudo apt-add-repository 'deb bionic main in the setup instructions, I run into this error:

Hit:1 focal InRelease
Get:2 focal-security InRelease [114 kB]
Get:3 focal-updates InRelease [114 kB]
Hit:4 stable InRelease
Hit:5 InRelease
Hit:6 InRelease
Hit:7 InRelease
Hit:8 bionic InRelease
Hit:9 focal InRelease
Get:10 focal InRelease [52.1 kB]
Get:11 focal-backports InRelease [101 kB]
Err:12 jessie InRelease
402 Payment Required [IP: 2600:1f1c:2e5:6901:48c1:8c0c:948d:3ce7 443]
Hit:13 focal InRelease
Reading package lists… Done
E: Failed to fetch 402 Payment Required [IP: 2600:1f1c:2e5:6901:48c1:8c0c:948d:3ce7 443]
E: The repository ‘ jessie InRelease’ is no longer signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Hello @dylan_miller

It looks like one of your apt repositories is giving the error. Kitware also made cmake installable using pip. You can run the following to install the latest version of cmake from kitware.

pip install -U cmake


1 Like

Hi @jyotish
It looks like that worked. python runs at any rate. Thank you.

1 Like