ML-Agents Version Mismatch

#1

Hi,

I’ve been trying to use the obstacle tower environment together with the ml-agents toolkit. However, when I try to start the training process I get this error: “The API number is not compatible between Unity and Python. Python API : API-8, Unity API : API-6” If I understand it correctly it seems that my ml-agents version is higher than the one used to build the environment. Is there some place where I can download the tower Unity environment with a ml-agents version 8? For now I just downgraded Ml-agents to version 0.6 but if would be cool if it is possible to use the newest version somehow.
Thank you for any help!

0 Likes

#2

Hi @vkakerbeck

As of right now we only support v0.6.2 of ml-agents for Obstacle Tower. In the next release we will upgrade the project to use the latest ML-Agents version.

1 Like

#3

Hi @arthurj,
the new version 2.0 looks like it still requires ml-agents<0.7. Will there be another update?

1 Like